I am getting some implementation-related warnings on Google Play Console for my Android application built on Volt MX. Below is the snippet for the same:
Here, you can see that it is specifically for the androidx.fragment.fragment and currently the Iris is using its v1.0.0
So, I thought of upgrading the required thing via the IRIS app. I added the new versions for android annotation and fragment inside the gradle suffix entries.
After I build the apk/aab file, inside the gradle file, I can see the required dependencies with the right version. But when I analyze the APK via Android Studio, I am unable to spot any configuration for annotation or fragment. (The billing one was correctly updated)
And this is the reason that Play Console is giving those warnings. How can I rectify the versions for the dependencies?
Even I tried placing the same in the prefix section, but it threw an error (even though, the dependencies were being placed at the start of the gradle file)
Can anyone help?
Hi Vishal,
The warning says <<Consider updating to a newer version (1.1.0+)>>. In the shared screenshot we see the version used is <<implementation 'androidx.fragment:fragment:1.1.0'>
Please try updating the version to a version greater than 1.1.0 or newer.
Thank you.
Thanks for the reply @Madhuri Choutkur. I guess you misinterpreted the question. As you can see according to the Play Console warning, I am supposed to use version 1.1.0 or higher and in my grade configuration, I have explicitly defined its version to be 1.1.0 (which is right within the required specifications)
The third screenshot is from the build.gradle file that is supposedly made from the specifications we provide in the IRIS app (and rightly matches with what I have instructed IRIS). But the issue is, that the Google Play console is saying that in my application, 'androidx.fragment:fragment:1.0.0 is used.
Even though specifying the v1.1.0 for the same in the gradle file, and the correct version provided to the gradle file, the apk which is built has a default version that is used by IRIS internally v1.0.0 is transcended to the finalized apk and thus the error is shown.
So, I am asking how can I rectify that.
Can I get a reply, @Suhas Bhat @Murali Boddeda ?
@Suhas Bhat @Madhuri Choutkur @Naveen Kumar Kuppili @Analyn Policarpio @Nina Brown can I please get a response to my query?
It's weird and unacceptable to see that after asking a query, I do not receive any response from the team.
Hi @Vishal Vats ,
But when I analyze the APK via Android Studio, I am unable to spot any configuration for annotation or fragment.
And this is the reason that Play Console is giving those warnings. How can I rectify the versions for the dependencies?
I think u can find out the version by unzipping the APK file. Then, u will see the VERSION-FILES like the one below, with the version code written inside.
YOUR-APPNAME.apk\META-INF\androidx.fragment_fragment.version
Thanks for the reply, @mingchuan liu, I did that earlier. But my query is that despite defining the new versions of some of the dependencies, IRIS is automatically calling them down to a pre-defined version.
Here, you can see that I have set the versions, but in the APK, the versions for both of these are set to 1.0 The same warning is given by the Play Console.