Nevermind…was a directory catalog issue.
My Domino system has taken it upon itself to continue forwarding email to an employee that left the company some time ago and has since been removed from the Domino directory. A forwarding address had been set up in their directory document and was in operation for a few months. About a month ago I deleted this person from the directory and placed their name in a deny access group. Even so, SMTP mail arriving for this individual is forwarded on to their personal ISP account.
Mail is not forwarded for other ex-employees listed in the same deny access group. The mail is rejected when they are not found in the Domino directory.
Has anyone seen behavior like this before?