I am having a strange issue. I cannot issue console command from the Administrator client unless I am running a live console. This also means that clicking “Server Tasks” or “Database Users” in the Server/Status tab fails. It will come back after a minute with the error “Network Operation didn’t complete in a reasonable amount of time”.
If I look at the log, I can see where the commands are issued. The result of that command is also printed out in the log. It’s just that that result never makes it back to the admin client.
As part of troubleshooting this, I started the server (running on RedHat ES 3.0) with an interactive console so I could see exactly what’s happening server side. What I see is something like…
show tasks > /rem3493493.con (number part is arbitrary)
On W32, the file is usually written to the temp dir. The Linux uid which runs the domino server doesn’t have access to write to the root so I am guessing that might be what’s causing the failure. However, I can’t see anywhere to make that temp file write to /tmp. I have a $TMP, $TEMP, $TMPDIR, and $TEMPDIR env variables setup for the Linux uid underwhich the server runs. All of these point to /tmp.
Also, when using webadmi client, I get a similar situation with the addition log output of this…
03/21/2005 06:23:12 PM Agent message: -------------------------------
03/21/2005 06:23:12 PM Agent message: Domino Web Administrator Error:
03/21/2005 06:23:12 PM Agent message: (Please report the error below
03/21/2005 06:23:12 PM Agent message: to IBM Lotus software support)
03/21/2005 06:23:12 PM Agent message: -------------------------------
03/21/2005 06:23:12 PM Agent message: Notes error: No response from server for this command in:
03/21/2005 06:23:12 PM Agent message: -->wqoMainHome$UserL2:INITIALIZE (70)<–
03/21/2005 06:23:12 PM Agent message: -------------------------------
Lastly, this issue seems to be impacting my ability to use Server.Load.
Any help is appreciated.
Thanks
Zach Mabe