Trusted Server Error with Scheduled Agent!

Hi All,

I have two servers A and B.I have added server B as a trusted server in Server A’s server document.I have a scheduled agent in a DB on Server A which tries to open a database in server B.

I am getting this error in the agent.

Error 4164: To open database (SevrerB…!!names.nsf) on remote machines the server where the agent is running has to be listed by remote machine as trusted server at line number 7

I have this code at line 7

Set database = session.GetDatabase(“ServerB…/Domain”,“xyz.nsf”)

In the agent properties, i selected Run on “Any Server”.

I have the access to run unrestricted agents on ServerB.

When i debug this agent, the database is picked up without any error.

Do i need to change any other settings in Server document? Does the server need to be restarted when its server document gets updated.Do i need to have a connection Document for this pair of servers?

Awaiting your reply.

Thanks in Advance,

Sudheer Kondapalli

Subject: Trusted Server Error with Scheduled Agent!

You need to understand the trusted server field (security remifications), and then set the value in the server record. The best place to find info is1) Admin Guide

  1. Agent FAQ article “Decoding ND6 agents”

(has explanation and screen shots). Agent FAQ is on the left under Forum FAQs

I think you have the servers reversed. The server where the database resides has to have the other server in the server record listed. The server with the database gives permission to access its data.

Subject: RE: Trusted Server Error with Scheduled Agent!

Hi Becca!Thanks for the response.I have gone through the article “Decoding ND6 agents”,but could not get any more information.

I completely agree with your explanation of Trusted Server concept.In my case also the server with the database gives the permission to access its data.

I found that the same configuration works fine for a combination of servers,say A and B.But i get the Trusted Server error between A and C.

What i want to know is that,if i am trying to establish a connection between a pair of servers for the first time(and apparently for opening a database on a server which trusts the current server)what are the settings need to done (other than the Trusted field in Server document).

Thanks in Advance,

Sudheer Kondapalli

Subject: Solved - Trusted Server Error with Scheduled Agent!

I was able to solve this problem,Eventhough i mentioned Sever B as a Trusted Server for Server A, it (server B)is found in one of the Deny Access groups which is resulting in server denying access.

Thanks

Sudheer