We are using two separate IP address for two domino servers partitions on the same Windows 2003 machine. We are unable to get both controllers to load, when they are started as a service, because Windows is socket pooling 2050 (at the DOS prompt: netstat -na). The 2nd controller service to load errors out with the message that it cannot bind to the port. When the domino servers are started from the start menu, Windows does not socket pool them and everything works great.
I have read the instructions on setting up multiple domino controllers to run partition servers and how to edit the dcontroller.ini (below). Has anyone been able to configure Windows to not socket pool the 2050 socket, when the controllers are loaded as services?
Subject: Partitioned Domino Controllers on Win2003
I’ve done this at my former job with 3 Domino servers on one Windows 2000 machine with them all starting up as a service (1 with the -jc switch, the others with -jc -c).The clue here is the dcontroller.ini file in each partition. In this file you’ll find the line:
Host_Name=
This line should contains the FQDN of your server like it is in your server document and obviously, the windows server has to be able to resolve this hostname to the IP address of that specific partition.
I’ve had some problems with this setup due to a bug in Domino up to 6.0.2 CF1. I haven’t tracked this one since then, so I don’t know if this bug has been resolved since.
The problem was that if the windows server failed to resolve the hostname, Domino would simply change the dcontroller.ini so that the Host_name line would contain the name of the local machine. The result would be that one controller would start (totally random which one), and the others would give the error message which you also mentioned. You can imagine that if the server starts while there are network problems, this bug will occur. A restart of the server then doesn’t bring up all servers and you’ll need to manually correct all dcontroller.ini’s to correct the problem. As said, I don’t know if this bug has been fixed yet.
Otherwise, the 3 domino partitions with separate controllers on one machine worked brilliantly.
Subject: RE: Partitioned Domino Controllers on Win2003
Thanks Martijn.
I have been able to make it work using Windows 2000 as you described. The problem only seems to be on Windows 2003 Enterprise and Web additions. It does not matter what port the dcontroller is set to in the dcontroller.ini. Windows will socket pool the port if Domino is loaded as a service.
I hope the developers at Lotus can get Microsoft to tell us how to disable socket pooling for the dcontroller (or services in general for that matter).