Out of office agent not working

On my domino server no outofoffice agent works.

i receive the following error:

“Agent ‘OutOfOffice|OutOfOffice’ error: Notes error: Connection denied. The server you connected to has a different name from the one requested.”

moreover when users return in their office, they dont receive the warning to disable the agent.

i checked the agent setting on the config document of the server and they are correct.

i also checked with the amgr commands the execution list and it is correct.

who can help me? thank you

Subject: OUT OF OFFICE AGENT NOT WORKING

Have you checked the server that this agent runs on by opening the mail file in designer, looking at the agent properties and verifying the server name is correct in the target.

Subject: RE: OUT OF OFFICE AGENT NOT WORKING

thanks for your quick reply :slight_smile:

i m sorry but i can t find the parameter you told me about in the agent properties.

i opened the db in designer and checked the agent parameters, but i don t see a field called target or server

can you help me?

Subject: RE: OUT OF OFFICE AGENT NOT WORKING

Open the Agent. Then check the Agent Properties.

On the Schedule button it will show you the schedule and server the agent will run on.

Basically, whoever activates the OOF, the server specified in their location document will be used.

If this is not the same server that the NAB has specified for that user, then the agent will never come across any mail to work on.

Subject: RE: OUT OF OFFICE AGENT NOT WORKING

i think i talked too early… since the out of office still has some problems.

i checked the log file and the error previously mentioned doesnt appear any longer… but no message is sent back to inform of the absence.

i tried many times and i also forced the process from the console with the command TELL AMGR RUN “DB” ‘AGENT’

it still doesnt work. please help

Subject: RE: OUT OF OFFICE AGENT NOT WORKING

Hi Nicolla,

The Out of office agent works once a day, by 2AM if I’m not wrong.

You will send messages today and tomorrow morning you will get one response for all the mails you sent today.

Don’t change this because you can have other problems, like ping pong between servers.

Hope this help,

Daniel

Subject: RE: OUT OF OFFICE AGENT NOT WORKING

The Out of Office message will only be sent to an address once.

This list is cleared when the agent is disabled.

Therefore, disable then enable the OOF agent and try again.

Check the Schedule as discussed before for how often it runs. I have found that standard Notes 6 template set it to every 6HRS, which is pretty useless.

Also, on the server it is set to run type

Tell AMgr Sched

This will list the scheduled agents with the times they will be acted upon. Check for the mailfile path of the database concerned.

Other checks would be to look at the Agent Interval settings in the Notes.ini - Check Admin Help - Improving Agent Manager performance.

NOTE: Known issue with servers that have been running for over 100days. Mail-triggered agents run with no error, but no mail is generated. To fix, restart Server box at NT level not just Domino.

Subject: RE: OUT OF OFFICE AGENT NOT WORKING

thank you , i ll try and i ll bother you again if it doesnt work

thanks a lot

you are very kind

best regards

Subject: RE: OUT OF OFFICE AGENT NOT WORKING

thank you now it works :smiley: